I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
SPDMEM(4) Device Drivers Manual SPDMEM(4) NAME spdmem - Generic Memory Module Serial Presence Detect SYNOPSIS spdmem* at iic? addr 0x50 spdmem* at iic? addr 0x51 spdmem* at iic? addr 0x52 spdmem* at iic? addr 0x53 spdmem* at iic? addr 0x54 spdmem* at iic? addr 0x55 spdmem* at iic? addr 0x56 spdmem* at iic? addr 0x57 DESCRIPTION The spdmem driver provides support for generic memory module Serial Presence Detect. During kernel boot it displays module type, and where possible, the size and rated speed of the memory module. Additional information such as bank configuration and width is printed if the kernel is booted in verbose mode. The Serial Presence Detect data for each memory module is also made accessible to user mode via sysctl(8). An entry for each spdmem device is created under the hw top-level MIB. Some SPD ROMs also have a temperature sensor. It's supported by sdtemp(4). SEE ALSO iic(4), intro(4), sdtemp(4) HISTORY The spdmem driver first appeared in NetBSD 5.0. AUTHORS The spdmem driver was written by Nicolas Joly <firstname.lastname@example.org> with additional work by Paul Goyette <email@example.com>. NetBSD 8.0 July 27, 2016 NetBSD 8.0