I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
TXP(4) Kernel Interfaces Manual TXP(4) NAME txp -- 3Com 3XP Typhoon/Sidewinder (3CR990) Ethernet interface SYNOPSIS txp* at pci? dev ? function ? DESCRIPTION The txp interface provides access to the 10Mb/s and 100Mb/s Ethernet networks via the 3Com Typhoon/Sidewinder chipset. This driver supports the following cards: o 3Com 3CR990-TX-95 o 3Com 3CR990-TX-97 o 3Com 3CR990SVR95 o 3Com 3CR990SVR97 Basic Ethernet functions are provided as well as support for vlan(4) tag removal and insertion assistance, receive ip(4), tcp(4), and udp(4) checksum offloading, and transmit ip(4) checksum offloading. There is currently no support for transmit tcp(4) or udp(4) checksum offloading, tcp(4) segmentation, nor ipsec(4) acceleration. Note that hardware checksumming is only used when the interface is not in bridge(4) mode. Each of the host's network addresses is specified at boot time with an SIOCSIFADDR ioctl(2). The txp interface employs the address resolution protocol described in arp(4) to dynamically map between Internet and Ethernet addresses on the local network. When a txp interface is brought up, by default, it will attempt to auto- negotiate the link speed and duplex mode. The speeds, in order of attempt, are: 100Mb/s Full Duplex, 100Mb/s Half Duplex, 10 Mb/s Full Duplex, and 10 Mb/s Half Duplex. The txp supports several media types, which are selected via the ifconfig(8) command. The supported media types are: media autoselect Attempt to autoselect the media type (default) media 100baseTX mediaopt full-duplex Use 100baseTX, full duplex media 100baseTX [mediaopt half-duplex] Use 100baseTX, half duplex media 10baseT mediaopt full-duplex Use 10baseT, full duplex media 10baseT [mediaopt half-duplex] Use 10baseT, half duplex SEE ALSO arp(4), ifmedia(4), inet(4), intro(4), ip(4), netintro(4), pci(4), tcp(4), udp(4), vlan(4), ifconfig(8) HISTORY The txp driver first appeared in NetBSD 2.0. NetBSD 7.1.2 August 21, 2003 NetBSD 7.1.2