Updated: 2022/Sep/29

Please read Privacy Policy. It's for your privacy.


UKYOPON(4)                   Device Drivers Manual                  UKYOPON(4)

NAME
     ukyopon - Kyocera AIR-EDGE PHONE support

SYNOPSIS
     ukyopon* at uhub?
     ucom*    at ukyopon? portno ?

     #include <dev/usb/ukyopon.h>

DESCRIPTION
     The ukyopon driver provides support for Kyocera AIR-EDGE PHONE AH-K3001V.

     Two units of this driver attach to an AIR-EDGE PHONE: the modem port and
     the data transfer port.  The modem port is compatible to umodem(4), and
     can be used for dialup connections.  The data transfer port is for
     reading and writing internal storage of AIR-EDGE PHONE.

     Both devices are accessed through the ucom(4) driver which makes them
     behave like a tty(4).

     The manipulation of the internal storage is through external programs,
     for example, the pkgsrc/comms/kyopon package.

IOCTLS
     The following ioctl(2) calls apply to the ukyopon device:

     UKYOPON_IDENTIFY struct ukyopon_identify
             Read, from the kernel, the identification information of the
             device, useful to assure that the opened device node is a modem
             or a data transfer port of ukyopon device.

             struct ukyopon_identify {
                     char    ui_name[16];            /* driver name */

                     int     ui_busno;               /* usb bus number */
                     uint8_t ui_address;             /* device address */

                     enum ukyopon_model {
                             UKYOPON_MODEL_UNKNOWN
                     } ui_model;                     /* possibly future use */
                     enum ukyopon_port {
                             UKYOPON_PORT_UNKNOWN,
                             UKYOPON_PORT_MODEM,     /* modem port */
                             UKYOPON_PORT_DATA       /* data transfer port */
                     } ui_porttype;                  /* port type */
                     int     ui_rsvd1, ui_rsvd2;
             };
             #define UKYOPON_NAME            "ukyopon"

             The ui_name field contains the driver signature, and has the
             string UKYOPON_NAME.

             The ui_busno field contains the usb(4) bus number to which the
             device is connected; the ui_address field contains the address of
             the device in the bus.  These fields are useful to identify the
             physical device from the file descriptor.

             The ui_porttype field contains the type of device:
             UKYOPON_PORT_MODEM means the device is associated to the modem
             port, and UKYOPON_PORT_DATA means the device is associated to the
             data transfer port.

             Other fields are reserved for future extension and cleared to
             zeros.

     In addition, ukyopon devices accept all ioctl(2) calls that umodem(4)
     accepts.

SEE ALSO
     tty(4), ucom(4), umodem(4), usb(4), pkgsrc/comms/kyopon

HISTORY
     The ukyopon driver appeared in NetBSD 3.0.

NOTES
     "Kyopon" is a widely-used nickname of Kyocera AIR-EDGE PHONE.

NetBSD 10.99                     May 18, 2005                     NetBSD 10.99