Updated: 2022/Sep/29

Please read Privacy Policy. It's for your privacy.


WSBELL(4)                    Device Drivers Manual                   WSBELL(4)

NAME
     wsbell - generic bell support in wscons

SYNOPSIS
     wsbell*    at spkr? console?

DESCRIPTION
     The wsbell driver utilizes the speaker(4) driver to provide a system bell
     with or without a keyboard for the wscons(4) framework.  When a bell
     character is received on a wsdisplay(4) screen, wsbell sounds the bell.

     The wsconsctl(8) utility gives access to several configurable parameters
     that effect the sound of the system bell.

   Ioctls
     The following ioctl(2) calls are provided by the wsbell driver.  Their
     definitions are found in dev/wscons/wsconsio.h.

     WSKBDIO_BELL  Will sound the default bell.

     WSKBDIO_GETBELL
                   Will return a struct wskbd_bell_data with the current bell
                   parameters.

     WSKBDIO_SETBELL
                   Takes a struct wskbd_bell_data and uses it to set the bell
                   parameters.  These are used by the WSKBDIO_BELL ioctl(2)
                   call.

     WSKBDIO_COMPLEXBELL
                   Will sound a bell using a supplied struct wskbd_bell_data
                   for its parameters.

     WSKBDIO_GETDEFAULTBELL
                   Will return a struct wskbd_bell_data with the default bell
                   parameters.

     WSKBDIO_SETDEFAULTBELL
                   Takes a struct wskbd_bell_data and uses it to set the
                   default bell parameters.

     Ioctls use the following structure:

     struct wskbd_bell_data {
             u_int   which;                  /* values to get/set */
     #define WSKBD_BELL_DOPITCH      0x1     /* get/set pitch */
     #define WSKBD_BELL_DOPERIOD     0x2     /* get/set period */
     #define WSKBD_BELL_DOVOLUME     0x4     /* get/set volume */
     #define WSKBD_BELL_DOALL        0x7     /* all of the above */
             u_int   pitch;                  /* pitch, in Hz */
             u_int   period;                 /* period, in milliseconds */
             u_int   volume;                 /* percentage of max volume */
     };

FILES
     /usr/include/dev/wscons/wsconsio.h.

SEE ALSO
     speaker(4), wscons(4), wskbd(4), wsmux(4), wsconsctl(8), wsbell(9)

NetBSD 10.99                     June 13, 2017                    NetBSD 10.99