I would appreciate any donations. Wishlist or send e-mail type donations to maekawa AT daemon-systems.org.
AC97(4) Device Drivers Manual AC97(4) NAME ac97 - generic AC97 codec driver DESCRIPTION AC97 codecs contain the analog-to-digital (A/D), digital-to-analog (D/A), and mixing circuitry of many modern sound cards. AC97 codecs, for the most part, do not talk to host busses like the PCI bus directly. Instead, they communicate through an interface chip, called the host controller. The Ensoniq AudioPCI 97 (see eap(4)) is an example of such a host controller. Unlike many drivers, the ac97 driver does not appear in the configuration file. Instead, the driver is automatically attached by the drivers that require it. SEE ALSO auacer(4), auich(4), auixp(4), autri(4), auvia(4), clcs(4), clct(4), eap(4), emuxki(4), esa(4), esm(4), fms(4), neo(4), yds(4) BUGS The ac97 driver does not keep track of the current user settings and instead relies on the hardware to do this. The ac97 driver could do more to detect mixer channels that don't work and cull them from the list. NetBSD 8.0 October 7, 1999 NetBSD 8.0